Audio stops when skipping ahead or back in Fedora 35

After upgrading to Fedora 35, audio will stop in when I move ahead or back?

For example, if I am playing a video and I move the progress bar back 1 minute, the video will go back, but the audio will stop.

What to hear the chorus of a song again? Nope. The audio will stop as soon as I click on progress bar. Want to skip the commercial in a podcast? Nope. The audio will stop as soon as I skip a head 30 seconds.

This happens in all apps: Gnome Videos, Lollipop music player, VLC, Gnome Podcasts, etc.

If I start a song/podcast/video from the very beginning, and don’t touch it, the audio will work. Pause also works.

I am guessing this is an issue with the new WirePlumber. Is there a LUA script I could edit to fix this?

1 Like

In case this helps, systemctl --user status pipewire:

 pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor p>
    Drop-In: /usr/lib/systemd/user/pipewire.service.d
     Active: active (running) since Wed 2021-12-08 09:05:02 MST; 11h ago
TriggeredBy: ● pipewire.socket
   Main PID: 1669 (pipewire)
      Tasks: 2 (limit: 19047)
     Memory: 12.4M
        CPU: 7.132s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewi>
             └─1669 /usr/bin/pipewire

Dec 08 09:05:02 desktop-rye systemd[1399]: Started PipeWire Multimedia Service.
lines 1-14/14 (END)

And systemctl --user status wireplumber:

wireplumber.service - Multimedia Service Session Manager
     Loaded: loaded (/usr/lib/systemd/user/wireplumber.service; enabled; vendor>
     Active: active (running) since Wed 2021-12-08 20:14:41 MST; 33min ago
   Main PID: 33626 (wireplumber)
      Tasks: 4 (limit: 19047)
     Memory: 5.5M
        CPU: 497ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/wirepl>
             └─33626 /usr/bin/wireplumber

Dec 08 20:14:41 desktop-rye systemd[1399]: Started Multimedia Service Session M>

Could you please give us more infos as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

It looks like it worked with pipewire media session in F34?
So as workaround you could change from wireplumber back to media-session.

Releases/35/ChangeSet - Fedora Project Wiki
Last point 2.17 follow link for instructions.

1 Like

@ilikelinux Thanks for the quick response. Yes, it worked in F34. I’ll try switching to pipewire-media-session.

The output of inxi -Fzx:

  Kernel: 5.15.6-200.fc35.x86_64 x86_64 bits: 64 compiler: gcc
  v: 2.37-10.fc35 Desktop: GNOME 41.1
  Distro: Fedora release 35 (Thirty Five)
  Type: Desktop System: ASUS product: All Series v: N/A
  serial: <superuser required>
  Mobo: ASUSTeK model: Z87-PRO v: Rev 1.xx serial: <superuser required>
  UEFI: American Megatrends v: 1707 date: 12/13/2013
  Info: Quad Core model: Intel Core i7-4770K bits: 64 type: MT MCP
  arch: Haswell rev: 3 cache: L2: 1024 KiB
  flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  bogomips: 55963
  Speed: 1412 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1412 2: 1669
  3: 1188 4: 2266 5: 983 6: 2051 7: 1168 8: 1236
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
  vendor: Micro-Star MSI driver: amdgpu v: kernel bus-ID: 01:00.0
  Display: wayland server: X.Org compositor: gnome-shell driver:
  loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa
  resolution: 2560x1440~60Hz
  OpenGL: renderer: AMD Radeon RX 470 Graphics (POLARIS10 DRM 3.42.0
  5.15.6-200.fc35.x86_64 LLVM 13.0.0)
  v: 4.6 Mesa 21.3.1 direct render: Yes
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.15.6-200.fc35.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.40 running: yes
  Device-1: Intel Ethernet I217-V vendor: ASUSTeK driver: e1000e v: kernel
  port: f040 bus-ID: 00:19.0
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: ASUSTeK
  driver: ath9k v: kernel bus-ID: 03:00.0
  IF: wlp3s0 state: down mac: <filter>
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IF-ID-2: virbr0 state: down mac: <filter>
  Device-1: ASUSTek type: USB driver: btusb v: 0.8 bus-ID: 3-4:3
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 465.76 GiB used: 279.25 GiB (60.0%)
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-1: / size: 48.97 GiB used: 28.71 GiB (58.6%) fs: ext4 dev: /dev/dm-0
  mapped: fedora_localhost--live-root
  ID-2: /boot size: 975.9 MiB used: 282.1 MiB (28.9%) fs: ext4
  dev: /dev/sda2
  ID-3: /boot/efi size: 598.8 MiB used: 13.9 MiB (2.3%) fs: vfat
  dev: /dev/sda1
  ID-4: /home size: 398.92 GiB used: 250.26 GiB (62.7%) fs: ext4
  dev: /dev/dm-3 mapped: luks-68dee735-03f1-433f-a7fe-3b46dd9e9714
  ID-1: swap-1 type: partition size: 7.85 GiB used: 0 KiB (0.0%)
  dev: /dev/dm-1 mapped: fedora_localhost--live-swap
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: amdgpu temp: 47.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 470
  Processes: 499 Uptime: 12h 13m Memory: 15.56 GiB used: 3.29 GiB (21.2%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.1 clang: 13.0.0
  Packages: 51 note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.09

1 Like


Switching to pipewire-media-session doesn’t fix the problem. It might only affect applications that use gstreamer, as Firefox and Brave seem to be OK. Others are having the same problem, see this thread:

Since I was able to recreate the problem on a second computer, I will file a bug report.


I’m experiencing that same problem on Fedora 35 Silverblue using Gnome Videos. Any movement of the tracking indicator stops audio, but videos keep playing.

1 Like