ASUS Laptop freezes on boot half of the time (on Silverblue)

Hi there,

I am experiencing some problems with my ASUS Laptop booting into Silverblue. I have Silverblue installed since a week or so. Prior to that, this laptop was running Windows 10 just fine. My Desktop PC has Fedora on it (and I love it), so I was intended to ‘upgrade’ my laptop with Silverblue. I will use this laptop for development work most of the time, and therefore really liked the idea of Silverblue.

So, what is the problem?
My laptop freezes during boot. It happens in two ways:
Symptom 1: At the ASUS logo screen. I think at the moment that the OS/bootloader will take over, but I am not sure. It just sits on the ASUS logo screen. The Fedora logo and spinner are also not visible.
Symptom 2: When the GRUB boot selection screen comes, I am able to make a selection. Or I can wait for the auto selection timer. After that, the system hangs on a blank screen with only ‘booting into [boot selection here]…’ on it.

I just hold the power button to force the system to shut off and try again. Most of the time, it works on the second try. But I also needed a third try once. The system works without any problems further on. The next time I do a cold start or a reboot, it is time to play ‘boot roulette’ again.

I am not sure how to troubleshoot this. I’ve seen someone with almost the same symptoms. He installed the nvidia drivers and had no problems after that. I tried to do the same, but that doesn’t work. I have also disabled secure boot, but that doesn’t seem to change anything either.

How can I troubleshoot this problem?

Information about my system:
Firmware (BIOS) version: N752VX.303
Memory: 24,0 GiB
CPU: Intel® Core™ i7-6700HQ × 8
GPU: NVIDIA GeForce GTX 950M / Intel® HD Graphics 530 (SKL GT2)
OS: Fedora Linux 38.20230511.0 (Silverblue)
Kernel: Linux 6.2.14-300.fc38.x86_64

Currently active deployment:

  Version: 38.20230513.0 (2023-05-13T00:46:58Z)
  BaseCommit: 0cb2293657eaba7b89c1c62d74fd69f6c7c42fe31b0df16fbae8708202377ab0
  GPGSignature: Valid signature by 6A51BBABBA3D5467B6171221809A8D7CEB10B464
  Diff: 16 upgraded
  LayeredPackages: kmod-nvidia langpacks-nl xorg-x11-drv-nvidia
  LocalPackages: rpmfusion-free-release-38-1.noarch rpmfusion-nonfree-release-38-0.2.noarch

One thing that I have noticed is that I never have seen the Fedora logo and the spinner on the ASUS logo screen while booting. My desktop (which is a DELL and running a normal version of Fedora) does this. I just see the ASUS logo until the login screen appears. Is this always the case on Silverblue installations?
The strange thing is: It does show the ASUS logo, Fedora logo and spinner when powering off the system.

I tried to start my laptop a moment ago and it needed three tries again.

  1. Hang on ASUS logo. No GRUB selection sreen
  2. Got the GRUB selection screen. Hang on the ‘Booting into Fedora silverblue…’ screen
  3. Got the GRUB selection screen again, this time it did boot.

Booting is fast when it is working. We are talking about seconds. As soon as the hard disk activitiy light starts to blink I know it: Its gonna boot. But yeah, I’m not very happy about hard resetting my system.

I still have no clue how to troubleshoot this. Can anyone help me in the right direction?