Asahi-branding-fixup.service fails at startup on rawhide

service seems to be misconfigured.

Linux lnx 6.8.10-400.asahi.fc41.aarch64+16k #1 SMP PREEMPT_DYNAMIC Mon May 27 16:06:46 UTC 2024 aarch64 GNU/Linux

systemctl status asahi-branding-fixup
Warning: The unit file, source configuration file or drop-ins of asahi-branding-fixup.service changed on disk. Run ‘systemctl daemon-reload’ to reload units.
○ asahi-branding-fixup.service - Fix Fedora Asahi branding packages
Loaded: bad-setting (Reason: Unit asahi-branding-fixup.service has a bad unit file setting.)
Drop-In: /usr/lib/systemd/system/service.d
└─10-timeout-abort.conf
Active: inactive (dead)

Jun 21 17:33:42 lnx systemd[1]: asahi-branding-fixup.service: Service has Restart= set to either always or on-success, which isn’t allowed for Type=oneshot services. Refusing.
Jun 21 17:33:42 lnx systemd[1]: asahi-branding-fixup.service: Service has Restart= set to either always or on-success, which isn’t allowed for Type=oneshot services. Refusing.

Known bug (cc @ngompa).

This should be in the process of being resolved as I’ve pushed a potential fix for it.

1 Like