Applications is beyond viewing screen

Hello, I am a new user to fedora, and I am facing issue with application like darktable where the applications part is out of screen estate needed to drag using mouse to use the app, same with librecad 2.2.0 appimage june 2022 release is there any workaround for it.

This looks like full screen mode although it goes off-screen to the left, and probably is default for darktable.
Can you drag the displayed window to the left so you can access the right portion of the app window? Or resize that window in any way?

The newer releases of fedora with gnome do not automatically display the ‘minimize’ and ‘full screen/windowed’ buttons on the upper right of the top tool bar for the windows.

The fix is to install gnome-tweaks then use tweaks to set those buttons active within the window settings. Once available you can then switch the app to a window that can be moved or resized.

1 Like

Thanks for the reply, I searched in the net and it seems to be default on dark table and there is no maximise buttonn for darktable as well as for CAD(ALT+F7) the maximise button is greyed out its even more worse in librecad you can see the screenshot the bottom part is offscreen and it cant be resized(see the specify next point arean in bottom right)

Are you using the flatpak for librecad or the rpm install?

I use freeCAD installed with dnf directly from fedora and do not have that problem.

I have to ask since some apps are still affected.
Are you using gnome or some other DE?
Are you using wayland or xorg? Wayland is default for fedora 36.

Some apps work properly under xorg but not under wayland (particularly flatpaks). It may be worth attempting the same things when logged in with the other DM (from the gear icon on the password entry screen) to see if this is the result of wayland or xorg.

1 Like

I am using librecad as an appimage from github asset, I am using fedora gnome version latest upto now, I tried xorg but I can’t see app list by pressing the windows button on xorg (it does nothing no loading screen just showing the DE).

I tried X11 its even worse on it , you can see the top part completely off screen and I cant see faltpak option of librecad in software centre

1 Like

Simply use keyboard combination Win/cmd + arrow up/down to maximize/minimize window, full screen being simply F11. The culprit maybe screen configuration adjusted simply in Gnome Settings/Displays, XOrg/Wayland can be manually tweaked with configuration file but you must stay in screen hardware capabilities … Gnome Tweaks allows effectively to remove top bar buttons as useless with a keyboard.

1 Like

Hey, the keycombination do not work its not responding to Win +up/down key neither any maximise button present even though I activated it via gnome tweaks, I dont know about the configuration file

1 Like

This is confusing (bold emphasis mine). Are you logging in using xorg or not.? How are you differentiating ‘xorg’ and ‘X11’. Are these all with one user or different users?

You seem to have complete mismatch between system configuration and hardware display, happens sometimes, with modern Gnome with no bottom toolbar goes unnoticed. Please go to Settings/Displays and toggle with different screen resolutions/proportions to find something that works even if the system window doesn’t completely fill the screen. It’s not a question about old/obsolete hardware, just exotic like the device I’m using with 10.5" touchscreen and 1800/1200 (3:2) display. Didn’t exactly snap in on initial installation.

I logged in with Gnome on xorg, and the windowing sytem on XOrg is x11 right , and the last part was edited instead of xorg I typed x11 sorry, but the issue still remains might have to change screen resolution.

Tried it, but no change. I am using dell inspiron 3552(old guy) with resolution set to default 16:9 1366*720

The only time I have had similar issues was when I first connected a tv as my monitor. I had to tell the PC I was using a tv instead of a standard monitor (or tell the tv it was not receiving standard input). While I think that was within the gnome settings arena it may also have been within the setup on the tv itself (maybe the picture ratio area). Has been some time so I do not remember for sure.

What are you using as a monitor?

Mine is a laptop dell inspiron 15, but even after adjusting the resolution of display there is no change it is still off screen

Are you sure that screen is 16:9? Maybe you should try the 4:3 aspect and see what happens.
Checking the specs from dell, those screen dimensions (336.63 mm x 225.06 mm) give an aspect of ~ 14.66:9 so a 16:9 image that fills the screen top to bottom would extend beyond the edge on the side.

The maximum pixel aspect from the same dell page shows 1366 x 768 which does give the 16x9.

Are you able to select 1280x720 (16x9)as one of the allowed values?

Tried the 1280*720 16:9 aspect ratio you can see the bottom part is off screen now.

Mine Default screen resolution

Taken from my phone as you can see in 4:3 aspect ratio the balck wasted screen area and still the bottom part of the application is cut off. Will it be an application issue.

Try running your apps windowed instead of full screen

windowed means? and is there any way too send files like videos between linux and android like nearby share gsconnect is too slow like 500kbps on my device.