Applications don't start anymore - After removing Nomachine?

Yesterday, everything was fine (F39/GNOME). Last thing I did was a dnf update. Today, I experienced, that a lot of gui applications don’t start anymore. Console (kgx), for example, doesn’t. But gnome-terminal works. Nautilis doesn’t show up, and many more. And I see journal massages like

warning: egl: failed to create dri2 screen

and

nautilus[6328]: libEGL warning: failed to open /dev/dri/renderD128: Keine Berechtigung
nautilus[6328]: libEGL warning: failed to open /dev/dri/renderD128: Keine Berechtigung
nautilus[6328]: libEGL warning: wayland-egl: could not open /dev/dri/renderD128 (Keine Berechtigung)

Firefox starts but is very slow. about:support is also suspicous:

I’m somehow lost and wonder what has happened.

Any ideas what I could do? I have a Radeon RX5500 graphics card. Could it be a hardware problem? How can I tackle it down?

Thanks a lot
Martin

1 Like

Let’s give us more info:

sudo dnf history list shows you the history where you need the latest entry “NUMBER”

sudo dnf history info "NUMBER" shows you what exactly has been installed on the last update.

Please post the output of “info” to see what has changed. Remember to do that as pre formated text (using the </>symbol in the editor)

Sure. Yesterday I did two things:
Remove nomachine:

# LC_ALL=C dnf history info 296
Transaction ID : 296
Begin time     : Thu Mar 21 08:06:18 2024
Begin rpmdb    : bbd737d4ea270b92c08ddd439392bfa8ec237b11342471cf3d24975ab150a383
End time       : Thu Mar 21 08:06:57 2024 (39 seconds)
End rpmdb      : 2e51e71b5f0a38e8d0a224e7fd1e780c6a94aa2fbb23c8f355143d167694d774
User           : Martin <myuser>
Return-Code    : Success
Releasever     : 39
Command Line   : remove nomachine
Comment        : 
Packages Altered:
    Removed nomachine-8.11.3-5.x86_64 @@System
Scriptlet output:
   1 NX> 702 Starting uninstallation at: Thu, 21 Mar 2024 08:06:19.
   2 NX> 702 Uninstallation log is: /usr/NX/var/log/nxuninstall.log.
   3 NX> 702 Uninstalling nxserver version: 8.11.3.
   4 NX> 702 Uninstalling nxnode version: 8.11.3.
   5 NX> 702 Uninstalling nxplayer version: 8.11.3.
   6 NX> 702 Uninstalling nxrunner version: 8.11.3.
   7 NX> 702 Uninstallation completed at: Thu, 21 Mar 2024 08:06:54.
   8 /usr/NX/scripts/setup/nxrunner: Zeile 6982: [: -eq: Einstelliger (unärer) Operator erwartet.
   9 /usr/NX/scripts/setup/nxserver: Zeile 11594: [: -eq: Einstelliger (unärer) Operator erwartet.
  10 Warnung: Datei /usr/NX: remove failed: Datei oder Verzeichnis nicht gefunden
  11 Warnung: Datei /etc/NX: remove failed: Datei oder Verzeichnis nicht gefunden

And I did a dnf update:

LC_ALL=C dnf history info 297
Transaction ID : 297
Begin time     : Thu Mar 21 15:54:22 2024
Begin rpmdb    : 2e51e71b5f0a38e8d0a224e7fd1e780c6a94aa2fbb23c8f355143d167694d774
End time       : Thu Mar 21 15:55:01 2024 (39 seconds)
End rpmdb      : f72b591a064a5c9561be7dda2a2dbc35777cedf9032e5d690a5933f8e9a143b6
User           : Martin <myuser>
Return-Code    : Success
Releasever     : 39
Command Line   : update
Comment        : 
Packages Altered:
    Install  python3-defusedxml-0.7.1-9.fc39.noarch                         @fedora
    Upgrade  brave-browser-1.64.109-1.x86_64                                @brave-browser
    Upgraded brave-browser-1.63.174-1.x86_64                                @@System
    Upgrade  cpp-13.2.1-7.fc39.x86_64                                       @updates
    Upgraded cpp-13.2.1-6.fc39.x86_64                                       @@System
    Upgrade  firefox-124.0-1.fc39.x86_64                                    @updates
    Upgraded firefox-123.0.1-1.fc39.x86_64                                  @@System
    Upgrade  firefox-langpacks-124.0-1.fc39.x86_64                          @updates
    Upgraded firefox-langpacks-123.0.1-1.fc39.x86_64                        @@System
    Upgrade  gcc-13.2.1-7.fc39.x86_64                                       @updates
    Upgraded gcc-13.2.1-6.fc39.x86_64                                       @@System
    Upgrade  gcc-c++-13.2.1-7.fc39.x86_64                                   @updates
    Upgraded gcc-c++-13.2.1-6.fc39.x86_64                                   @@System
    Upgrade  gcc-gfortran-13.2.1-7.fc39.x86_64                              @updates
    Upgraded gcc-gfortran-13.2.1-6.fc39.x86_64                              @@System
    Upgrade  gcc-plugin-annobin-13.2.1-7.fc39.x86_64                        @updates
    Upgraded gcc-plugin-annobin-13.2.1-6.fc39.x86_64                        @@System
    Upgrade  koji-1.34.0-2.fc39.noarch                                      @updates
    Upgraded koji-1.33.1-2.fc39.noarch                                      @@System
    Upgrade  libaom-3.8.2-1.fc39.i686                                       @updates
    Upgraded libaom-3.8.0-1.fc39.i686                                       @@System
    Upgrade  libaom-3.8.2-1.fc39.x86_64                                     @updates
    Upgraded libaom-3.8.0-1.fc39.x86_64                                     @@System
    Upgrade  libatomic-13.2.1-7.fc39.i686                                   @updates
    Upgraded libatomic-13.2.1-6.fc39.i686                                   @@System
    Upgrade  libatomic-13.2.1-7.fc39.x86_64                                 @updates
    Upgraded libatomic-13.2.1-6.fc39.x86_64                                 @@System
    Upgrade  libcupsfilters-1:2.0.0-7.fc39.x86_64                           @updates
    Upgraded libcupsfilters-1:2.0.0-6.fc39.x86_64                           @@System
    Upgrade  libgcc-13.2.1-7.fc39.i686                                      @updates
    Upgraded libgcc-13.2.1-6.fc39.i686                                      @@System
    Upgrade  libgcc-13.2.1-7.fc39.x86_64                                    @updates
    Upgraded libgcc-13.2.1-6.fc39.x86_64                                    @@System
    Upgrade  libgfortran-13.2.1-7.fc39.x86_64                               @updates
    Upgraded libgfortran-13.2.1-6.fc39.x86_64                               @@System
    Upgrade  libgomp-13.2.1-7.fc39.i686                                     @updates
    Upgraded libgomp-13.2.1-6.fc39.i686                                     @@System
    Upgrade  libgomp-13.2.1-7.fc39.x86_64                                   @updates
    Upgraded libgomp-13.2.1-6.fc39.x86_64                                   @@System
    Upgrade  libquadmath-13.2.1-7.fc39.x86_64                               @updates
    Upgraded libquadmath-13.2.1-6.fc39.x86_64                               @@System
    Upgrade  libquadmath-devel-13.2.1-7.fc39.x86_64                         @updates
    Upgraded libquadmath-devel-13.2.1-6.fc39.x86_64                         @@System
    Upgrade  libstdc++-13.2.1-7.fc39.i686                                   @updates
    Upgraded libstdc++-13.2.1-6.fc39.i686                                   @@System
    Upgrade  libstdc++-13.2.1-7.fc39.x86_64                                 @updates
    Upgraded libstdc++-13.2.1-6.fc39.x86_64                                 @@System
    Upgrade  libstdc++-devel-13.2.1-7.fc39.x86_64                           @updates
    Upgraded libstdc++-devel-13.2.1-6.fc39.x86_64                           @@System
    Upgrade  libvirt-client-9.7.0-3.fc39.x86_64                             @updates
    Upgraded libvirt-client-9.7.0-2.fc39.x86_64                             @@System
    Upgrade  libvirt-daemon-9.7.0-3.fc39.x86_64                             @updates
    Upgraded libvirt-daemon-9.7.0-2.fc39.x86_64                             @@System
    Upgrade  libvirt-daemon-common-9.7.0-3.fc39.x86_64                      @updates
    Upgraded libvirt-daemon-common-9.7.0-2.fc39.x86_64                      @@System
    Upgrade  libvirt-daemon-config-network-9.7.0-3.fc39.x86_64              @updates
    Upgraded libvirt-daemon-config-network-9.7.0-2.fc39.x86_64              @@System
    Upgrade  libvirt-daemon-driver-interface-9.7.0-3.fc39.x86_64            @updates
    Upgraded libvirt-daemon-driver-interface-9.7.0-2.fc39.x86_64            @@System
    Upgrade  libvirt-daemon-driver-network-9.7.0-3.fc39.x86_64              @updates
    Upgraded libvirt-daemon-driver-network-9.7.0-2.fc39.x86_64              @@System
    Upgrade  libvirt-daemon-driver-nodedev-9.7.0-3.fc39.x86_64              @updates
    Upgraded libvirt-daemon-driver-nodedev-9.7.0-2.fc39.x86_64              @@System
    Upgrade  libvirt-daemon-driver-nwfilter-9.7.0-3.fc39.x86_64             @updates
    Upgraded libvirt-daemon-driver-nwfilter-9.7.0-2.fc39.x86_64             @@System
    Upgrade  libvirt-daemon-driver-qemu-9.7.0-3.fc39.x86_64                 @updates
    Upgraded libvirt-daemon-driver-qemu-9.7.0-2.fc39.x86_64                 @@System
    Upgrade  libvirt-daemon-driver-secret-9.7.0-3.fc39.x86_64               @updates
    Upgraded libvirt-daemon-driver-secret-9.7.0-2.fc39.x86_64               @@System
    Upgrade  libvirt-daemon-driver-storage-9.7.0-3.fc39.x86_64              @updates
    Upgraded libvirt-daemon-driver-storage-9.7.0-2.fc39.x86_64              @@System
    Upgrade  libvirt-daemon-driver-storage-core-9.7.0-3.fc39.x86_64         @updates
    Upgraded libvirt-daemon-driver-storage-core-9.7.0-2.fc39.x86_64         @@System
    Upgrade  libvirt-daemon-driver-storage-disk-9.7.0-3.fc39.x86_64         @updates
    Upgraded libvirt-daemon-driver-storage-disk-9.7.0-2.fc39.x86_64         @@System
    Upgrade  libvirt-daemon-driver-storage-gluster-9.7.0-3.fc39.x86_64      @updates
    Upgraded libvirt-daemon-driver-storage-gluster-9.7.0-2.fc39.x86_64      @@System
    Upgrade  libvirt-daemon-driver-storage-iscsi-9.7.0-3.fc39.x86_64        @updates
    Upgraded libvirt-daemon-driver-storage-iscsi-9.7.0-2.fc39.x86_64        @@System
    Upgrade  libvirt-daemon-driver-storage-iscsi-direct-9.7.0-3.fc39.x86_64 @updates
    Upgraded libvirt-daemon-driver-storage-iscsi-direct-9.7.0-2.fc39.x86_64 @@System
    Upgrade  libvirt-daemon-driver-storage-logical-9.7.0-3.fc39.x86_64      @updates
    Upgraded libvirt-daemon-driver-storage-logical-9.7.0-2.fc39.x86_64      @@System
    Upgrade  libvirt-daemon-driver-storage-mpath-9.7.0-3.fc39.x86_64        @updates
    Upgraded libvirt-daemon-driver-storage-mpath-9.7.0-2.fc39.x86_64        @@System
    Upgrade  libvirt-daemon-driver-storage-rbd-9.7.0-3.fc39.x86_64          @updates
    Upgraded libvirt-daemon-driver-storage-rbd-9.7.0-2.fc39.x86_64          @@System
    Upgrade  libvirt-daemon-driver-storage-scsi-9.7.0-3.fc39.x86_64         @updates
    Upgraded libvirt-daemon-driver-storage-scsi-9.7.0-2.fc39.x86_64         @@System
    Upgrade  libvirt-daemon-driver-storage-zfs-9.7.0-3.fc39.x86_64          @updates
    Upgraded libvirt-daemon-driver-storage-zfs-9.7.0-2.fc39.x86_64          @@System
    Upgrade  libvirt-daemon-kvm-9.7.0-3.fc39.x86_64                         @updates
    Upgraded libvirt-daemon-kvm-9.7.0-2.fc39.x86_64                         @@System
    Upgrade  libvirt-daemon-lock-9.7.0-3.fc39.x86_64                        @updates
    Upgraded libvirt-daemon-lock-9.7.0-2.fc39.x86_64                        @@System
    Upgrade  libvirt-daemon-log-9.7.0-3.fc39.x86_64                         @updates
    Upgraded libvirt-daemon-log-9.7.0-2.fc39.x86_64                         @@System
    Upgrade  libvirt-daemon-plugin-lockd-9.7.0-3.fc39.x86_64                @updates
    Upgraded libvirt-daemon-plugin-lockd-9.7.0-2.fc39.x86_64                @@System
    Upgrade  libvirt-daemon-proxy-9.7.0-3.fc39.x86_64                       @updates
    Upgraded libvirt-daemon-proxy-9.7.0-2.fc39.x86_64                       @@System
    Upgrade  libvirt-libs-9.7.0-3.fc39.x86_64                               @updates
    Upgraded libvirt-libs-9.7.0-2.fc39.x86_64                               @@System
    Upgrade  nextcloud-client-3.12.1-1.fc39.x86_64                          @updates
    Upgraded nextcloud-client-3.11.0-1.fc39.x86_64                          @@System
    Upgrade  nextcloud-client-libs-3.12.1-1.fc39.x86_64                     @updates
    Upgraded nextcloud-client-libs-3.11.0-1.fc39.x86_64                     @@System
    Upgrade  nextcloud-client-nautilus-3.12.1-1.fc39.x86_64                 @updates
    Upgraded nextcloud-client-nautilus-3.11.0-1.fc39.x86_64                 @@System
    Upgrade  pciutils-3.11.1-1.fc39.x86_64                                  @updates
    Upgraded pciutils-3.10.0-3.fc39.x86_64                                  @@System
    Upgrade  pciutils-libs-3.11.1-1.fc39.x86_64                             @updates
    Upgraded pciutils-libs-3.10.0-3.fc39.x86_64                             @@System
    Upgrade  perl-LWP-Protocol-https-6.14-1.fc39.noarch                     @updates
    Upgraded perl-LWP-Protocol-https-6.13-1.fc39.noarch                     @@System
    Upgrade  python3-koji-1.34.0-2.fc39.noarch                              @updates
    Upgraded python3-koji-1.33.1-2.fc39.noarch                              @@System
    Upgrade  thunderbird-115.9.0-1.fc39.x86_64                              @updates
    Upgraded thunderbird-115.8.1-1.fc39.x86_64                              @@System
    Upgrade  thunderbird-librnp-rnp-115.9.0-1.fc39.x86_64                   @updates
    Upgraded thunderbird-librnp-rnp-115.8.1-1.fc39.x86_64                   @@System
    Upgrade  thunderbird-wayland-115.9.0-1.fc39.x86_64                      @updates
    Upgraded thunderbird-wayland-115.8.1-1.fc39.x86_64                      @@System
    Upgrade  pipewire-codec-aptx-1.0.4-1.fc39.x86_64                        @rpmfusion-free-updates
    Upgraded pipewire-codec-aptx-1.0.3-1.fc39.x86_64                        @@System
    Upgrade  vivaldi-stable-6.6.3271.53-1.x86_64                            @vivaldi
    Upgraded vivaldi-stable-6.6.3271.50-1.x86_64                            @@System

Nothing suspicious, as far as I can tell.

By the way, I did a eglinfo, which does not return/end:

# eglinfo 
EGL client extensions string:
    EGL_EXT_client_extensions, EGL_EXT_device_base, 
    EGL_EXT_device_enumeration, EGL_EXT_device_query, EGL_EXT_explicit_device, 
    EGL_EXT_platform_base, EGL_EXT_platform_device, EGL_EXT_platform_wayland, 
    EGL_EXT_platform_x11, EGL_EXT_platform_xcb, 
    EGL_KHR_client_get_all_proc_addresses, EGL_KHR_debug, 
    EGL_KHR_platform_gbm, EGL_KHR_platform_wayland, EGL_KHR_platform_x11, 
    EGL_MESA_platform_gbm, EGL_MESA_platform_surfaceless

GBM platform:
eglinfo: eglInitialize failed

Wayland platform:
error: XDG_RUNTIME_DIR is invalid or not set in the environment.
error: XDG_RUNTIME_DIR is invalid or not set in the environment.
error: XDG_RUNTIME_DIR is invalid or not set in the environment.
eglinfo: eglInitialize failed

X11 platform:

And glxinfo shows mit literally nothing (does not return as well, I have to do CTRL-C to exit).

In the meantime, I started Fedora Live from USB stick. Here, everything seems to be ok and glxinfogives me reasonable output. So I think it’s not a hardware problem. :thinking:

I just saw that you use two architectures, what sometimes causes problems. If you not need i686 alias 32bit apps I propose to remove them.

You might also have a look for problems in bugzilla, searching with keywords from your update list.

I also think it is not direct hardware problem but might be a driver problem. Sometimes it happens that there is a regression. This means a fix where already was present in an older kernel got forgotten or is just not up to date yet. If you upgrade a kernel you always can check with an older one from the boot menu.

I think wine and/or steam is the reason for 32bit.

Yes, I already tried the available kernel versions.

I will try. But right now I’m ouf ideas. The problem came out of nowhere.

I finally solved it.

Some package (how can I found out, which?) installed /etc/udev/rules.d/99-virtualgl-dri.rules, which has changed the permissions of /dev/dri/card1 as well as /dev/dri/renderD128. That was the reason for the permission issues.

Since dnf whatprovides /etc/udev/rules.d/99-virtualgl-dri.rules couldn’t tell me, to which package the file belongs, I moved it out of /etc. Now, the permissions are as expected:

crw-rw----+ 1 root video  226,   1 25. Mär 08:28 card1
crw-rw-rw-. 1 root render 226, 128 25. Mär 08:28 renderD128

And everything works again.

I’m seeing a similar issue with permissions for /dev/dri in Windows for debian wsl2 with wslg, which makes me think some package is responsible for the misconfiguration. No time to investigate at present.

Seams to be an old silly typo, you might check:

No, the content of 99-virtualgl-dri.rules was:

KERNEL=="card*|renderD*", MODE="0660", OWNER="root", GROUP="vglusers"

My WSL2 debian system was giving messages like this when trying to run Firefox. The permissions on /dev/dri/renderD128were crw-rw----. Changing to crw-rw-rw-. got rid of some error messages, but Firefox still fails to start.

Since dnf whatprovides /etc/udev/rules.d/99-virtualgl-dri.rules didn’t provide an owner, It is possible that file is generated by some post-install script, or some attempt to reverse changes made when a package was installed and later removed. It could be helpful to reinstall nomachine and look at /usr/NX/scripts.

A day or two later, and permissions on /dev/dri/renderD128are back to crw-rw----.

So i do not want to incriminate Nomachine, but i have experienced the exact same issue after installing and removing nomachine form my laptop.

Thanks a lot because i was running crazy!

1 Like

I concur with what Bean Kylla wrote. The exact same thing just happened to me yesterday. System is a laptop, HP ZBook Fury 15 G7 15.6” 4k W-10885M 64GB 1TB RTX 5000. Fedora 39 was completely patched, up to date, and working great. I installed Nomachine via RPM. The program its self wouldn’t reliably connect and created some wonky graphics issues. So after a couple hours of diagnostics I uninstalled the RPM and wiped the remnant files. Upon reboot it started having this issue. The fix mentioned above solved it.

Nomachine was for sure the problem in my case. That’s three people now on Fedora 39 with the same problem after uninstalling Nomachine.

Nomachine is not a Fedora Package.

Since NoMachine version 4, the software is proprietary and currently two editions are available: Free and Enterprise. Clients exist for Linux, MS Windows, macOS, Android and iOS.

Please report it to Nomachine if you want to support proprietary software:

https://www.nomachine.com/report-an-issue

1 Like

To add to what was just said.

Any user who installs software that is either out-of-tree (third party, even if it is FOSS) or proprietary must be willing to trouble shoot and repair problems if their machine winds up broken. Such breakage is not the responsibility of fedora and you cannot file bug reports on that situation.

Not saying it is. Considering that three people in the last month have now had the exact same scenario (including OP and someone two days ago) I was confirming.

1 Like

No one is saying it was. If your issue is the bug report, then your insight is a month late. As it is, it’s probably clear now this isn’t a Fedora issue per se. But others will run into it. Perhaps confirming here makes it more visible so they won’t bother y’all in the future, eh?

For what it’s worth I have already reported it to Nomachine, and they don’t appear to care.

1 Like

Same here under gnome on solus os. After removing nomachine i had the exact same issue. Thanks for working this out and providing this information here.

Does Solus also use rpm packages?
Probably would be a good idea to report to them and give them the link to this topic. So they could fix it.

It may not be nomachine directly but some other package (ab?)used by nomachine. /dev/dri/renderD128 went missing in a Debian WSL2 instance that did not use nomachine, and there are similar reports with other distros, so it is possible that nomachine is an innocent bystander, or that nomachine doesn’t support Fedora’s handling of udev’s. The Debian issue was transient. renderD128 went missing, then reappeared with bad permissions. Unfortunately I was busy at the time so couldn’t investigate.

Fedora has (system with no dGPU):

% udevadm info /dev/dri/renderD128
P: /devices/pci0000:00/0000:00:02.0/drm/renderD128
M: renderD128
R: 128
U: drm
T: drm_minor
D: c 226:128
N: dri/renderD128
L: 0
S: dri/by-path/pci-0000:00:02.0-render
E: DEVPATH=/devices/pci0000:00/0000:00:02.0/drm/renderD128
E: DEVNAME=/dev/dri/renderD128
E: DEVTYPE=drm_minor
E: MAJOR=226
E: MINOR=128
E: SUBSYSTEM=drm
E: USEC_INITIALIZED=5612282
E: ID_PATH=pci-0000:00:02.0
E: ID_PATH_TAG=pci-0000_00_02_0
E: DEVLINKS=/dev/dri/by-path/pci-0000:00:02.0-render
E: TAGS=:mutter-device-disable-kms-modifiers:
E: CURRENT_TAGS=:mutter-device-disable-kms-modifiers:

The permissions and links are controlled by files in /lib/udev:

% grep -F render /lib/udev/rules.d/*.rules
/lib/udev/rules.d/50-udev-default.rules:SUBSYSTEM=="drm", KERNEL!="renderD*", GROUP="video"
/lib/udev/rules.d/50-udev-default.rules:SUBSYSTEM=="drm", KERNEL=="renderD*", GROUP="render", MODE="0666"
/lib/udev/rules.d/50-udev-default.rules:SUBSYSTEM=="kfd", GROUP="render", MODE="0666"
/lib/udev/rules.d/50-udev-default.rules:SUBSYSTEM=="accel", GROUP="render", MODE="0666"
/lib/udev/rules.d/60-drm.rules:KERNEL=="renderD*",  ENV{ID_PATH}=="?*",                   SYMLINK+="dri/by-path/$env{ID_PATH}-render"
/lib/udev/rules.d/60-drm.rules:KERNEL=="renderD*",  ENV{ID_PATH_WITH_USB_REVISION}=="?*", SYMLINK+="dri/by-path/$env{ID_PATH_WITH_USB_REVISION}-render"
grep: /lib/udev/rules.d/60-nfs.rules: Permission denied
1 Like