Applications can't use files on SMB-share

I tried a couple of fedora versions, I tried the XFCE-spin and I tried Gnome-version and I always have to copy files to my homefolder before I can open them. Sometimes I cannot access the shares at all. Mu SMB-Shares are published by a Synology NAS specified to accept SMB 2.1 as minimum protocol. I like fedora otherwise (not gnome, though). On XFCE I think i temporarily got partial function when I messed around with something called “gvfs” or something of the sort. Please advise.

Do you have the gvfs-smb package installed?

1 Like

With which applications?

1 Like

Did you have a look at How to create a Samba share :: Fedora Docs already? It describes some common problems inlucing the right SELinux content for the directory where the share is mounted to.

It’s important to have a look at the logs and why establishing a connection is failing (logs viewing described in above link).

How does your mount command look like? Please share. Are you specifying the protocol version?

mount -t cifs -o vers=2.1,username=none,password=none share /mountpoint

Can you try a newer samba protocol? You should use at least smb3 for performance and security reasons.

Yes, I have gvfs-smb-1.50.3-1.fc37.x86_64 installed.

It used to be more applications (e.g. I had problems with LibreOffice on the XFCE-spin), but today (gnome) when I tried a number of them had started working. VYM, however is still not working.

I consider myself a lazy n00b-user so I open gnome-files and click on “+ Other places”->My NAS->Share->[login]->Folder To get to the files I want. I don’t know where they are mounted using what command.

The share is published on a Synology NAS. In Fedora it seems to be mounted as:


tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,seclabel,size=1613240k,nr_inodes=403310,mode=700,uid=1000,gid=1000,inode64)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
portal on /run/user/1000/doc type fuse.portal (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)

GNOME and KDE apps rely on GIO/GVFS and KIO modules respectively to process network protocols like SMB/FTP/SFTP/etc. and open files by their URL.

Apps must be compiled with GIO or KIO support in order to use it, and the appropriate VFS modules require to be installed, otherwise you need to follow the path to the mount point.

Back when I was running Fedore XFCE version then NO applications could open files on share. Sometimes I couldn’t even logon to the share at all. The reason I am writing this here is to make sure that this use case is part of the testing being done before each release.

The large desktop environments like Gnome and KDE (and Windows) offer solutions to access files on a network by a kind of URL without mounting or mapping drive letters. This may extend to application’s file open and save dialogs. A lightweight desktop as XFCE does not offer this, so you need to setup a mount as augenauf described. If this works, you can store it in /etc/fstab, and it will be mounted automatically. In any case use the “_netdev” mount option to prevent hangup during boot. Additionally, use the uid and gid options to define the user who has access to the share, and
“credentials=file” to move the login data out of the publicly readable fstab. Then you have full access to the share by referring to the mount point, both from file dialogs and command line.