Applications cannot detect Nvidia driver after update

I recently ran the dnf upgrade command and after doing it, apps like mpv and system monitor spew out the error of it can’t detect drivers.

So I went and installed the sudo dnf install akmod-nvidia package again, says it is up to date.

The Nvidia X server settings are also present.

  • uname: 5.16.12-200.fc35.x86_64
  • Fedora 35 KDE spin.
  • 980Ti

Any ideas on why this is happening?

The message you post does not say it cannot find the driver, but is related to software rendering instead of hardware acceleration.

Your kernel is 5.16.12 and fedora 35 now uses 5.16.18, which tells me the system has not been updated recently.

You have a 980Ti GPU. You don’t say which version of the nvidia driver is installed, but we can see if you post the output of dnf list installed *nvidia* and inxi -Fzx.

I also would suggest that you do a full sudo dnf upgrade followed by a reboot as soon as possible since there have been many updates across the board since the 5.16.12 kernel was released. You said you updated but that kernel tells me you either did not reboot or did not do the update recently.

1 Like

dnf list installed *nvidia*

Installed Packages
akmod-nvidia.x86_64                                          3:510.60.02-1.fc35                   @rpmfusion-nonfree-updates
kmod-nvidia-5.16.11-200.fc35.x86_64.x86_64                   3:510.47.03-2.fc35                   @@commandline             
kmod-nvidia-5.16.12-200.fc35.x86_64.x86_64                   3:510.60.02-1.fc35                   @@commandline             
kmod-nvidia-5.16.18-200.fc35.x86_64.x86_64                   3:510.60.02-1.fc35                   @@commandline             
nvidia-settings.x86_64                                       3:510.60.02-1.fc35                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                   3:510.60.02-1.fc35                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                         3:510.60.02-1.fc35                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                           3:510.60.02-1.fc35                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                              3:510.60.02-1.fc35                   @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-power.x86_64                             3:510.60.02-1.fc35                   @rpmfusion-nonfree-updates

inxi -Fzx

Running the upgrade again, could be that the sudo expired last time.

 Installing       : kernel-5.16.19-200.fc35.x86_64

Going to reboot soon.

That output from the nvidia packages shows a driver was built for the 5.16.18 kernel but inxi shows you were running the 5.16.12 kernel. There are things that get updated but are not suitable for use with the older kernel so it is always a good thing to reboot as soon as the update is completed, especially when a kernel is updated.

It is possible that this update then rebooting will fix your problem. Please let us know.

BTW, just for future reference.
Pastebin normally only keeps items available for 1 day, so details that should be available for long term should be either directly in the post or stored in some location that has long-term storage so they can be referenced by others at a future date.

I did set it to 2 weeks, didn’t want my stuff up there for ever actually, but I do understand where you are coming from.

Tried to pipe output to but forgot how I should do it.

I am actually running this kernel:


After updating and rebooting ofcourse.

Now things work fine!

So the update followed by the reboot appears to have fixed it. Good!

sending output to a file is simple this way.
command > myfile

That is great, so then if I want to upload it to do I:

uname -a > output.txt
curl -F'file=@output.txt'

If the web site allows an upload that way then it should work.

This is off topic from the original so it should be taken to a new thread for this discussion.