Applications appear closed after resume from sleep


After sleep (closing lid or using Sleep button) all applications opened before are now closed (browser, file manager, terminal, etc)

Asus ROG Strix G15
Fedora 35
Kernel: 5.15.7-200.rog.fc35.x86_64

Some help over here please?


We need a little more info.
Are you by chance using nvidia GPU?
If you are using an nvidia GPU are you using the nvidia drivers?
When did this start? New install? Update? Version upgrade?

Please post the output of inxi -Fzx in </> Preformatted text tags (tool bar above)

Yes of course

I think that maybe this could start happening after upgrade… I installed Fedora and right after install completed, upgrade 1.2GB

System:    Kernel: 5.15.7-200.rog.fc35.x86_64 x86_64 bits: 64 compiler: gcc v: 2.37-10.fc35 Console: pty pts/5
           Distro: Fedora release 35 (Thirty Five)
Machine:   Type: Laptop System: ASUSTeK product: ROG Strix G513IM_G513IM v: 1.0 serial: <filter>
           Mobo: ASUSTeK model: G513IM v: 1.0 serial: <filter> UEFI: American Megatrends LLC. v: G513IM.310 date: 07/16/2021
Battery:   ID-1: BAT0 charge: 92.1 Wh (100.0%) condition: 92.1/90.0 Wh (102.3%) volts: 17.3 min: 15.9
           model: AS3GWAF3KC GA50358 status: Full
CPU:       Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 2 rev: 1 cache:
           L2: 4 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92628
           Speed: 1213 MHz min/max: 400/4300 MHz boost: enabled Core speeds (MHz): 1: 1055 2: 1243 3: 1107 4: 1099 5: 1101
           6: 1100 7: 1104 8: 2084 9: 1054 10: 1097 11: 1152 12: 1206 13: 1077 14: 1059 15: 1148 16: 1137
Graphics:  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia v: 495.44 bus-ID: 01:00.0
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 05:00.0
           Display: server: X.Org driver: loaded: amdgpu,nvidia unloaded: fbdev,modesetting,nouveau,vesa failed: ati
           resolution: 1920x1080~300Hz
           OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.7-200.rog.fc35.x86_64 LLVM 13.0.0) v: 4.6 Mesa 21.3.1
           direct render: Yes
Audio:     Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 01:00.1
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir Radeon High Definition Audio vendor: ASUSTeK
           driver: snd_hda_intel v: kernel bus-ID: 05:00.1
           Device-3: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK driver: N/A
           bus-ID: 05:00.5
           Device-4: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus-ID: 05:00.6
           Sound Server-1: ALSA v: k5.15.7-200.rog.fc35.x86_64 running: yes
           Sound Server-2: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000
           bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Device-2: MEDIATEK vendor: AzureWave driver: mt7921e v: kernel port: N/A bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
           IF-ID-1: virbr0 state: up speed: 10 Mbps duplex: unknown mac: <filter>
           IF-ID-2: vnet0 state: unknown speed: 10 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: IMC Networks Wireless_Device type: USB driver: btusb v: 0.8 bus-ID: 3-4:3
           Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
           address: see --recommends
Drives:    Local Storage: total: 476.94 GiB used: 332.63 GiB (69.7%)
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNU512GZ size: 476.94 GiB temp: 35.9 C
Partition: ID-1: / size: 337.7 GiB used: 332.62 GiB (98.5%) fs: btrfs dev: /dev/nvme0n1p9
           ID-2: /boot/efi size: 101.8 MiB used: 13.8 MiB (13.6%) fs: vfat dev: /dev/nvme0n1p7
           ID-3: /home size: 337.7 GiB used: 332.62 GiB (98.5%) fs: btrfs dev: /dev/nvme0n1p9
Swap:      ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p8
           ID-2: swap-2 type: zram size: 8 GiB used: 306.2 MiB (3.7%) dev: /dev/zram0
Sensors:   System Temperatures: cpu: 54.0 C mobo: N/A gpu: amdgpu temp: 45.0 C
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 455 Uptime: 22h 6m Memory: 15.11 GiB used: 7.76 GiB (51.4%) Init: systemd runlevel: 5 Compilers:
           gcc: 11.2.1 clang: 13.0.0 Packages: 18 note: see --pkg Shell: Bash v: 5.1.8 inxi: 3.3.09

PD: Sorry for my english, it’s not my primary language… Thanks for the help!

There are 2 possibilities here. Lets check first dnf list installed *nvidia* and post that output. There is one package and config we need to see that helps with suspend/hibernate on the nvidia cards and may be an issue here.

The second is the possibility that your system has a problem with the newer 495.44 drivers and it may be necessary to revert to the 470xx drivers.

akmod-nvidia.x86_64                                                                                                     3:495.44-1.fc35                                                                           @rpmfusion-nonfree-updates
kmod-nvidia-5.15.6-200.fc35.x86_64.x86_64                                                                               3:495.44-1.fc35                                                                           @@commandline             
kmod-nvidia-5.15.7-200.rog.fc35.x86_64.x86_64                                                                           3:495.44-1.fc35                                                                           @@commandline             
nvidia-persistenced.x86_64                                                                                              3:495.44-1.fc35                                                                           @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                                                                  3:495.44-1.fc35                                                                           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                                                                              3:495.44-4.fc35                                                                           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                                                                                         3:495.44-4.fc35                                                                           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.i686                                                                                      3:495.44-4.fc35                                                                           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                                                                    3:495.44-4.fc35                                                                           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                                                                      3:495.44-4.fc35                                                                           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.i686                                                                                           3:495.44-4.fc35                                                                           @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                                                                         3:495.44-4.fc35                                                                           @rpmfusion-nonfree-updates

Thanks again!

Try the instructions here. Install xorg-x11-drv-nvidia-power then enable all three services and see if there is any differences.

1 Like

Oh … seems to be fixed xD

sudo dnf install xorg-x11-drv-nvidia-power
sudo systemctl enable nvidia-{suspend,resume,hibernate}

This fix it, I had used already two times sleep-resume and the apps are still there, open :slight_smile:

Thanks a lot !


The issue has been with not properly saving & restoring the data from the GPU memory with suspend/hibernate and those 3 apps were developed to help with that. They are not needed if the screen is only locked, but suspend/hibernate are different.

1 Like