Annoying white bar in certain Flatpak apps (Discord, VSCodium, etc)

Hi, i’m having an issue with Fedora that there is this annoying title bar that says “File, Edit, View, etc”
It seems to happen only with Flatpaks as far as I’ve seen, and sometimes I need to use Flatpaks because they are the only version of apps I need that are available

(if the image does not work i’ll attempt to re-upload it, first time on this site)
Basically, what I want to know is that is there any way that I could at least disable or do something with this bar? even changing it to dark mode is fine, it’s actually what I want to do, since sometimes it’s needed.
I wasn’t able to find an answer about this anywhere, so I figured i’d ask here.

Looks something like this:

Seams to be a inconsistency of gtk3 <> gtk4 in the theme.

I tried this, I haven’t restarted yet but I have tried to re-open VSCodium and it seems like it is not working. It’s a very tough problem, I’ll restart now and see if it fixes it, will update.

I have tried this, sadly it seemed to have no effect. Even when entering the proper commands and selecting the proper theme and icons.

The package gtk4 is installed too?

how do i check?

sudo dnf list gtk4

Installed Packages
gtk4.x86_64                                                           4.10.4-1.fc38                                                           @updates
Available Packages

It shows you installed and available packages.

If you want to get more info of a package, to read what it does for example, you can use:
sudo dnf info gtk4

it’s installed, do i edit GTK4 as well?

I do not observe the same in my current configuration.
Gnome → Appearance is set to Dark
I’ve installed adw-gtk3, GitHub - lassekongo83/adw-gtk3: The theme from libadwaita ported to GTK-3 into the ~/.themes directory.
In Gnome Tweaks → Appearance → Legacy Applications set to Adw-gtk3-dark