Anbox on Fedora 33

So I decided to install anbox on my Fedora workstation.
$ lsb_release -a
LSB Version: :core-4.1-amd64:core-4.1-noarch
Distributor ID: Fedora
Description: Fedora release 33 (Thirty Three)
Release: 33
Codename: ThirtyThree

I quickly figured out that latest kernel does not work well with anbox modules, so i Installed long term Kernel . This had necessary modules out of the box.

$ uname -r

Then I installed anbox from snap.
$ snap info anbox

refresh-date: yesterday at 13:35 CET
latest/stable: –
latest/candidate: –
latest/beta: 4-56c25f1 2020-01-02 (186) 391MB devmode
latest/edge: 4+gitr7787751 2021-02-24 (208) 413MB devmode
installed: 4-56c25f1 (186) 391MB devmode

My Anbox installation was not starting apparently because of SELinux. I could not solve it the way it is proposed in one post i read. Even as root it failed , so I changed SElinux from Restrictive to Permissive. Afterward I got Anbox manager running.

I Installed Playstore with this script.

I gave all Permission for Google store and Google Services as adviced, but then I could not log in into my Google account because of connectivity issues.

I remembered that there was another script for bridging internet connection. So i did:

sudo ./ start

The script does not accept “status” argument but if I type the same command again I see it is running.

sudo ./ start
anbox-bridge is already running

So i erased data for google play store and google services and tried to log in again but i got the same error stating that there is connectivity issue. So I installed with adb tools firefox and tried to search something random to verify that the problem is with internet connectivity and not with google play store itself. This confirmed that i do not have internet access.

However when I check my Network adapters. I see anbox is there.

$ ifconfig anbox0
anbox0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::c83d:34ff:fe4d:f3f8  prefixlen 64  scopeid 0x20<link>
        ether ca:3d:34:4d:f3:f8  txqueuelen 1000  (Ethernet)
        RX packets 1102  bytes 68358 (66.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 932  bytes 93443 (91.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

What am I missing here? I know that anbox is still in Beta stage so I am not surprised that it is crashing time to time, but perhaps I am just missing some tweaks which makes it run better and get the network working.

As a new user i can not share more than two links…Therefore I did not source everything…

1 Like