Anaconda crash: NoneType object has no attribute 'getPartitionByPath'

Hi, I just tried installing Fedora KDE, but the anaconda installer crashed with the above error message. Fedora Workstation crashed with the same error, so I suspect there’s a general bug in anaconda at the moment.

This error left my system in a state where the existing fedora installation I was trying to replace was no longer boot able.

The error seemed to occur after the installer created the encrypted LUKS partition, but I can’t be sure.

Do you also have windows on that machine?

1 Like

Nope, I just had a single Fedora installation on there. The same error happened even when I manually deleted the existing partitions and started from an empty disk.

Check if this works for you as it seems to be the same kind of issue:

Thanks for the link. That seems to be a different error though, but do you think the solution would also apply in this case?

I think this evening I’ll try to replicate the problem by installing to a spare hard disk, and see how it goes.

I just tried installing Fedora to a completely empty USB drive, and ran into the same issue.