AMD Turbo Boost Not Working


Why is my AMD Turbo Core (boost clock) not active?

It’s supported but not active. My CPU Frequency never go above 3.1 Ghz when running single threaded load. How can I Fix this? For my use case, current performance is enough. But if I can get those 700Mhz extra performance I will be so happy.

I tried boot from Windows PE Hiren’s boot CD My CPU can run 3.7 - 3.8 GHz easily.

Tried some fix from google but didn’t work.

sys/devices/system/cpu/cpufreq/boost boost ic active (1)


Also I set my voltage in UEFI just 1.2 V so my CPU not running too hot. But it stays 1.380 V default. How can I fix this? Is there any tool to undervolt my CPU?

  1. I tried live Nobara and tried load my cpu, It boost to 3.8 GHz. It made noticeable performance difference in single threaded load. So what is different between Nobara and Vanilla Fedora?

My current spec is

AMD A8 7600 iGPU

Asrock FM2A68HM-DG3+

8 GB RAM running at 1833 Mhz

120 GB SSD btrfs

Fedora 36 Workstation Edition

Thanks in advance.

This you better ask by Nobara. On their page it has a list about the changes.

Ok thanks

I found solution from discord
This is kernel issue.
I try custom kernel from this (Nobara uses this too)

My CPU now works as supposed to be

1 Like