AMD GPU - Driver is not found or not configured

Morning all,

Long story short, Fedora 40, fresh install, Desktop Environment does not work. I can get into command line and everything is fully functional there.

Hardware probe is telling me the AMD GPU Driver is not found or not configured.

I am trying to download the correct driver (from the command line) and install it.
There appears to be little help on this in the www as “the drivers are in the kernel, they should be installed there is no problem”… but here I am with a none working GPU.

Many thanks for any pointers in the correct direction…

r/Fedora - AMD GPU - Driver is not found or not configured

There have been other reports of problems with AMD Radeon and 6.9 kernels.

We need more information in order to help. Note that posting images of system details means others with similar hardware and issues or solutions won’t find your post with web searches, so you may get less help than you would by posting text. Please post the output of inxi -Fzxx (as preformatted text using the </> icon from the top line of the text entry panel). This will give as a better understanding of your hardware. It is best if you can ensure that all vednor firmware is

Information we need:

  • Which graphics driver(s) were used by the Fedora Workstation installer?
  • Is the system a desktop or laptop?
  • Do you intend to use Xorg or Wayland?
  • Does the system have both iGPU and dGPU or is the AMD Radeom 8870 dGPU the only GPU?
  • Do you have any other OS’s installed?
  • Have you updated vendor firmware?
  • Does the dGPU work if you boot an older kernel?
  • Exactly what happens when you boot 6.9.5? (e.g., do you the GUI login or a blank screen where use for a terminal?

You may find useful details by using the GRUB editor to remove RHGB quiet from the kernel command line and using journalctl. For the latter, try, in a terminal (again, posting as pre-fromatted text): journalctl --no-hostname -b -p 4|cat. (the |cat just ensure that the very long lines journalctl can produce won’t be truncated when you past text). Use man journalctl to read up on the many options available to select ony relevant messages.

1 Like

@newuser42 First and foremost, Welcome to :fedora:

You can try : journalctl --no-hostname -b -p 4|fpaste --raw-url and paste the url here.

Also, Which version of Mesa do you have.
from what I have seen, the GPU ( GCN ) is covered for support under Mesa.

Also try : dnf install xorg-x11-drv-amdgpu mesa-dri-drivers mesa-vulkan-drivers