All threads high utilization on Wayland with latest bits; no Nvidia driver again

I just updated to the latest F37 bits on my AMD 7950X system. On restart all 32 threads are showing between 45% and 95% utilization, and the Nvidia driver is no longer being loaded.

Everything was working fine before I updated to latest bits.

I tried logging out in order to log back in using X11 but I couldn’t get back to a login screen. This was a bug that was supposed to have been fixed with the latest KDE bits.

I rebooted the machine and logged in using X11 and the threads are behaving themselves but the Nvidia driver is still not being loaded - I’m back to using the Mesa driver; nouveau is blacklisted. I had this working for a few weeks with rpmfusion bits.

So it looks like the thread utilization issue was related to the Nvidia driver not loading issue which seems to have been caused by a BIOS update which silently re-enabled Secure Boot. Once I’d disabled that again the Nvidia driver is loading and the threads are no longer showing high utilization (they were all stuck in kwin_wayland). I don’t know why the Nvidia driver not loading would produce such behavior however. Theoretically I can re-enable Secure Boot and it should reproduce.

However, the bug with logging off a single user rendering the machine unusable until it’s rebooted is still present on both Wayland and X11. I’ll update the bugzilla entry.

1 Like

You can also follow the instructions in /usr/share/doc/akmods/README.secureboot and enable signing of the nvidia driver modules. Once that is done then the nvidia driver will load even with secureboot enabled so that issue will disappear.

The caveat is that for the current kernel with unsigned modules, once the user has done the above and enabled signing the nvidia modules before secure boot can be enabled the user must do the following to sign the modules before rebooting.

  1. perform the kmodgenca -a command shown in the file above to create the key and enable signing the modules. Also do the mokutil import command as shown in that same file but do not do the reboot step yet.
  2. dnf remove kmod-nvidia-$(uname -r) to remove the modules for the current kernel
  3. akmods --force --kernels $(uname -r) to rebuild the modules that were just removed. This time they will be signed.
  4. After the modules have been rebuilt now reboot as shown in the README file above, and this time after importing the key, enter bios and enable secure boot. The signed driver modules should now be loaded.

Note that all these steps require the use of sudo with the commands.

1 Like