Airplane mode activating itself

Fedora 39 WS
Yoga 7 16" (16ARP8)

Does anyone else find their Airplane mode randomly activates without any keypresses?
I can’t work out what’s causing it, if anything specific. Just wondered if this is a known issue?

Added gnome

I can imagine that this has to do with your power-saving mode you choose.

What are the settings in the power configuration?

On the other topic you made, you mentioned that the Bluetooth speaker not works as expected. Could it be that the speaker has a power-saving mode who switches off the connection to your Computer?

Thank you. I don’t think power is related to bluetooth but I won’t rule it out. It just seems to be that Fedora bluetooth doesn’t ‘see’ a microphone in all devices that would otherwise be ‘seen’ (by mac or windows) to have a microphone. I can of course see if anything changes with different power settings.

I have never touched the power configs/settings. Checking it now, it says “Balanced”. I have changed to “Performance”. No change in detecting mic in bluetooth speaker.

Have to say, I am getting more and more bugs, may have to give up soon and look to change my machine to something more ‘built for Linux’. Just in this 10 min session:

  1. Wired network won’t reactivate after sleep, have to pull plug (ethernet) and replug, then still didn’t work so had to turn off Wired, and back on, instant internet. Doesnt often do that but sometimes it does and it’s frustrating

  2. VPN (via built in wireguard connection) doesn’t recover from sleep.

  3. Cant make signal calls unless I disconnect VPN and reconnect, sometimes many times. Will check that’s not a signal issue but it never happened on Mac Signal, I use a VPN 247.

  4. When I DO get a Signal call running, I can chat for an hour or two with a close friend (a few evenings a week), and during every call the dang screen goes into “Activities mode” (show all windows), and I have to get up and click the trackpad to select the call window to bring the app back to full screen. very annoying! Should have got a machine more linux-friendly OOTB, but the only desirable models I could find are Carbon X1 Yogas and they are a lot of money and I really never could get used to the keyboard mushroom ‘trackpoint’ thingie, and the 4 mouse clicky buttons!

Anyway, didn’t want to get off topic!
To be honest, this Airplane mode is so random and I am certain it happens without me touching anything (mouse/keyboard/entire machine), that I think it’s just a bug. If this weren’t a brand new machine, I’d say it’s a hardware fault where the F8 key (native airplane mode shortcut) has dust or a short underneath or something but that’s virtually impossible with it being out of the factory box for a matter of weeks. The activities menu popping up is similar, almost as if the trackpad is a bit sensitive for Fedora and it ‘thinks’ I have swiped down with 3 fingers when I haven’t touched it. Maybe all of this is just compatibility (Lenovo Yoga 16ARP8 which isn’t ‘designed for Linux’.)

Now you are mixing up the two topics you have. Power-saving has nothing to do with the fact that Fedora not recognizes the Microphone of your Bluetooth device. I just mentioned the device, because of the possibility of power saving. If there are Wireless/Bluetooth devices without communication it is obvious that your computer switches on the airplane mode to save power.

The problem about mac/windows is that they mostly have closed source drivers. So to make such devices working on Linux the drivers have to be many times reverse engineered. This cost time and money. If nobody takes care about that quite a lot of devices are useless on Linux or they just work with older/or LTS kernels.

Many times with researching and tinkering it is possible to use officially unsupported devices. Unfortunately not a lot of Users have the patience to do so.

That is why I do understand your frustration but please do not blame Fedora alias the Linux project for your inconvenience. It has really to do with the way, how companies select low price components to keep the costs down.

Power settings do affect all network connections, including the radios which include both wifi and bluetooth.

I didn’t see that as obvious, not sure I do now either! But then not much of this stuff is obvious to me :smiley:

Yep this is one thing I am well aware of (I got a Macbook Pro to run Fedora a year ago, that was ‘fun’! (Not for me!) I have the patience, but lack even a basic level of knowledge to really be able to tinker with stuff like that without risking the integrity/security/reliability of my system. Basically I can just copy paste commands, which is fine in some cases from trustworthy sources, but not in others, and either way I don’t enjoy being so reliant on others for their kind suggestions or reddit groups and forums from random commenters! (It got me there with the Macbook, but I wasn’t happy with the amount of tweaks in my underlying system, at least not happy enough to commit 20 yrs of personal data to and rely on daily as my main machine. That’s when I got this Yoga machine, but still cut corners by choosing one that was very new and not fully linux-friendly, my bad.

I haven’t, and never would. I have huge admiration for all FOSS stuff, it’s why I am here, and I wouldn’t blame anybody but myself for having troubles with my machine (my machine choice was the mistake). The support I have received is way more than I expected and I can’t express how grateful I am for it. I’ve decided that even if I have to spend a year or more getting a machine set up just right, that’s what I am doing. I have had more than my fill of Apple, won’t use Apple gear again if I can help it, and Windows, well no point even commenting there, haven’t touched it since 95/NT!

Yes understood. But in this context (and I should have phrased better): “I don’t think power configuration is the cause of lack of bluetooth microphone being detected” (as Bluetooth works just fine, depending on the brand/type of device