After upgrading to Fedora 32, Dolphin requests root password for mounting partitions


In Fedora 31 and earlier, Dolphin would ask me for the user password (presumably using sudo or whatever to mount).

However, after upgrading to Fedora 32, it now asks me the root password. I don’t believe I have set a root password when I first installed Fedora (a long time ago) and I’ve been using sudo exclusively instead. Therefore I have to mount everything manually with sudo in Konsole (this still works, thankfully).

The dialog box is titled “Authentication Required - PolicyKit1 KDE Agent”. I don’t remember if this was different before. The content is the same, except the label next to the textbox now says “Password for root:”.

Program versions:

$ uname -a
Linux localhost.localdomain 5.9.12-100.fc32.x86_64 #1 SMP Wed Dec 2 15:58:24 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
$ plasmashell --version
plasmashell 5.18.5
$ kf5-config --version
Qt: 5.14.2
KDE Frameworks: 5.75.0
kf5-config: 1.0

The conundrum continues. I found this: [SOLVED] PolicyKit1 KDE Agent asks for root password instead of user / Applications & Desktop Environments / Arch Linux Forums suggesting that I need to set myself as an administrator in KDE system settings. However, I can’t find this anywhere in the system settings.

Then I found out there are different system settings for the administrator, which can be accessed via kdesu systemsettings. Unfortunately, it again asks for the non-existent root password, and sudo systemsettings, sudo kdesu systemsettings and kdesudo systemsettings don’t work.

EDIT: sudo systemsettings5 and sudo -i then systemsettings5 both give me a System Settings dialog box which looks somewhat different from the ordinary one, but again contains nothing “users” or “admin”.

I’ve also tried KUser (which I’ve managed to run with sudo), but I’m no wiser. It shows me being in my own group, wheel and a few more mundane groups (like cdrom). I’m not sure what else I could change there.

EDIT 2: Figured out I have to dnf install plasma-user-manager in order to get the User Manager tab in System Settings. Unfortunately it also doesn’t solve my problem. The checkbox “Enable administrator privileges for this user” can be flipped while sudo-ing but all it does is add/remove me from the wheel group, in which I already was.

1 Like

If sudo still works for you it is quite possible that you could do “sudo passwd root” to set a password for root then when it asks for the root password you would be able to enter a valid password.


Thanks, I’ve done that for now. However I read somewhere that using sudo and enabling root password at the same machine introduces security issues. I would prefer to have PolicyKit1 ask me for my own password. It seems to me that this is a problem somewhere in KDE PolicyKit1 settings, and not with sudo/su. Unfortunately I can’t figure out where these settings are stored.

AFAIK using both su and sudo is not by itself a risk.
A user switching to root by using su (or logging in as root) then forgetting where he is and issuing a command that can harm the system is the bigger risk there. Using sudo to give the user the ability to do commands that require root permissions is just as much a security risk IMHO. The advantage to using sudo is that every command issued requires the user to (a) recognize he is using root permissions by using sudo, (b) only need his own user password, (c) not be able to damage the system by issuing a command as his regular user when the same command could break things when issued as root.

Separating the security issue out, it is necessary for a user of a personally owned PC to be able to do maintenance and using sudo instead of su seems the better way to enable that for most users. Within an organization the security risks are much different and hopefully are properly managed by the system administrators.