After update Gnome won't start

I suspect this matches a previous topic but lack the experience to resolve it. Did all the things suggested in previous discussions.

Automatic update from 6.3.8-200.fc38.x86_64 to 6.3.12.fc38.x86_64 and on reboot Gnome won’t start. Gives the password prompt but enter password and get grey screen with a little gear in the lower right corner. Mouse is dead too. The O/S is working because I can get a terminal screen using very slow but it works. Sometimes the grey screen goes black for a few seconds and then comes back. I’ve done a hardware check on all the disks (LVM) using smartctl so it is unlikely to be a read problem during boot. Backing off to old version gives same problem.

How should I best go about debugging this?

Would you share HW specs ? Have you enabled RPMFusion ?

Please post the output of inxi -Fzxx. That can be gotten from the terminal by redirecting the output to a file then copying the content and pasting it into a post here.

Jeff: Here is the result of inxi -Fzxx:

  Kernel: 6.3.12-200.fc38.x86_64 arch: x86_64 bits: 64 compiler: gcc v: 2.39-9.fc38 Console: tty 4
    DM: GDM Distro: Fedora release 38 (Thirty Eight)
  Type: Desktop Mobo: ASUSTeK model: M5A88-M v: Rev X.0x serial: <filter>
    BIOS: American Megatrends v: 1202 date: 07/26/2012
  Info: quad core model: AMD FX-4100 bits: 64 type: MT MCP arch: Bulldozer rev: 2 cache:
    L1: 192 KiB L2: 4 MiB L3: 8 MiB
  Speed (MHz): avg: 1400 min/max: 1400/3600 boost: enabled cores: 1: 1400 2: 1400 3: 1400
    4: 1400 bogomips: 28799
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD RS880 [Radeon HD 4250] vendor: ASUSTeK M5A88-V EVO driver: radeon v: kernel
    arch: TeraScale ports: active: HDMI-A-1 empty: VGA-1 bus-ID: 01:05.0 chip-ID: 1002:9715
  Display: server: v: 1.20.14 with: Xwayland v: 22.1.9 compositor: gnome-shell driver: X:
    loaded: radeon unloaded: fbdev,modesetting,vesa dri: r600 gpu: radeon tty: 240x67
  Monitor-1: HDMI-A-1 model: Acer G276HL res: 1920x1080 dpi: 82 diag: 686mm (27")
  API: OpenGL Message: GL data unavailable in console for root.
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK M5A88-V EVO driver: snd_hda_intel v: kernel
    bus-ID: 00:14.2 chip-ID: 1002:4383
  Device-2: AMD RS880 HDMI Audio [Radeon HD 4200 Series] vendor: ASUSTeK M5A88-V EVO
    driver: snd_hda_intel v: kernel bus-ID: 01:05.1 chip-ID: 1002:970f
  API: ALSA v: k6.3.12-200.fc38.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.74 status: active (process) with: 1: pipewire-pulse status: active
    2: wireplumber status: active 3: pipewire-alsa type: plugin 4: pw-jack type: plugin
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK P8 series
    driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: e800 bus-ID: 03:00.0
    chip-ID: 10ec:8168
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Local Storage: total: 4.09 TiB used: 22.1 GiB (0.5%)
  ID-1: /dev/sda vendor: Seagate model: ST3500413AS size: 465.76 GiB speed: 6.0 Gb/s
    serial: <filter> temp: 31 C
  ID-2: /dev/sdb vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB speed: 6.0 Gb/s
    serial: <filter> temp: 33 C
  ID-3: /dev/sdc vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB speed: 6.0 Gb/s
    serial: <filter> temp: 31 C
  ID-4: /dev/sdd vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB speed: 6.0 Gb/s
    serial: <filter> temp: 31 C
  ID-5: /dev/sde vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB speed: <unknown>
    serial: <filter> temp: 31 C
  ID-1: / size: 48.91 GiB used: 14.6 GiB (29.8%) fs: ext4 dev: /dev/dm-0 mapped: fedora-root
  ID-2: /boot size: 973.4 MiB used: 336.9 MiB (34.6%) fs: ext4 dev: /dev/sda1
  ID-3: /home size: 4 TiB used: 7.17 GiB (0.2%) fs: ext4 dev: /dev/dm-2 mapped: fedora-home
  ID-1: swap-1 type: partition size: 7.66 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/dm-1
    mapped: fedora-swap
  ID-2: swap-2 type: zram size: 7.48 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
  System Temperatures: cpu: 31.0 C mobo: 34.0 C
  Fan Speeds (RPM): cpu: 1844 case-1: 971
  Power: 12v: 12.18 5v: N/A 3.3v: 3.38 vbat: N/A
  Processes: 242 Uptime: 7h 33m Memory: available: 7.48 GiB used: 1.13 GiB (15.1%) Init: systemd
  v: 253 target: graphical (5) default: graphical Compilers: gcc: 13.1.1 Packages: pm: rpm
  pkgs: N/A note: see --rpm Shell: Bash v: 5.2.15 running-in: tty 4 inxi: 3.3.27

I hope everything is here; this is a Windows machine and I had trouble getting a copy I could paste here.

Arturas I don’t have RPMFusion installed.

I took the liberty of editing your post and switching the formatting into the Preformatted text tags so it is more readable and not all in bold. Those can be gotten by either placing [```] (triple backquotes) on the lines preceding the text and following the text, or by highlighting the text after pasting it and using the </> button on the tool bar.

Looking at that it seems good except that you have an AMD RS880 GPU (HD 4250) and are using the radeon driver. It seems the radeon driver is older and not as well maintained as one would wish. The driver that is provided with fedora is ‘amdgpu’ and that may be part of the issue since amdgpu is the current driver for most amd GPUs.

According to AMD the driver for that card was last updated 2013, and is proprietary. Have you recompiled it with the latest kernel update?

I downloaded the driver file from amd and it unzips to a .run file that merely needs to be executed for installation (or updating). How do you normally do an update of the driver with new kernels?

Have you tried using both wayland and xorg as choices to see if there is a difference?

Will that card work with the amdgpu driver? or not?

I think the kernel driver for old AMD cards is called radeon, and this is expected. @johniliffe Have you installed any custom gpu driver or are you using the defaults from Fedora?

The latest kernels have been problematic for Radeon cards, see e.g. here. Can you still boot using the old kernel? If you can, just wait until a fixed kernel appears in updates, hopefully soon.

It also happen to my system with AMD 5625U with newest kernel update. But currently I’m stick with kernel 6.2.9-300.fc38.x86_64 which I know it works normal for my laptop.

Thanks folks, and thanks to Jeff for editing the post. I’m both new to this site and working on a borrowed Windows 7 laptop instead of my usual workstation. Don’t know why it posted as all large bold.

I have never updated the hardware drivers and I don’t know how to do that. I just grabbed the only spare computer, a former server, a few years ago when my then workstation failed and installed Fedora and I just let it update whenever it wants to. The wayland infrastructure is a choice that Fedora made at some point; I didn’t choose it over xorg/x11. I’ll have to look up how to
change that. There is no real graphic card, this is the internal CPU graphics facility. I’ll try the other AMD driver this morning and see if that resolves anything.

I think that answers Kalil’s questions too. I can still boot to a command line, sort of like DOS! That does allow some work to be done since I have to maintain our servers (using SSH/SCP), but no email on that machine. If Fedora plans to push a correction and if the automatic update function will still work that is my preferred approach.

No, I would advise against that. Installing proprietary drivers is a ticket for breaking your system. When the PC starts, keep pressing F8 until you see a grub boot menu, then select the oldest kernel version available. See if your system starts OK with that.

OK, I wasn’t comfortable trying that anyway.

The oldest kernel that I have on grub is 6.3.4-201.fc38.x86_64 and that fails the same way - gets to the password but when I enter it I get the little gear wheel in the bottom right corner and a solid grey screen. I can get the command line terminal OK by pressing .

I just ran: dnf clean all
and: dnf update

It cleaned 234 files I noticed the update had gnome-shell. It completed and I rebooted. Now the login screen is a mess but it works and I have the mouse active. Gets stuck when the programmes that start on boot try to start; I get the terminal window (unusable) and the mail window (Evolution) with an icon indicating it is inactive. The mouse cannot enter the background screen area (disappears) but stays active. None of the programmes will come active and Firefox fails to start at all.

I can still do a ctl-alt-f4 to get a terminal window that works.

I think a bit more analysis/testing may be useful!

Further comments: after several minutes everything jumped back to the login screen which is still a mess. Bright orange bar where you type the password and a wrong password disables the mouse in a rather odd way - any mouse movement causes the screen to flash and occasionally everything goes blank for a moment and then restores. ps -ef shows WebKitWebProces running. top shows several of these taking many seconds of time and with storage of several Gb.

I rebooted several times and the results are inconsistent; not always the same

I start to think this just might be a hardware failure. Try downloading memtest, putting it on a thumb drive, and booting from it. Run the test for a few hours. If everything is fine, burn Fedora 38 Workstation Live image onto that USB. Can you boot it and use it just fine?
Also, can you try to boot with a different graphics card installed?

In any case, when you experience issues as described, it would be good to save the current system logs using journalctl -b > journal.txt, upload it somewhere and link it here, so that we can see some error messages.

Sorry for the delay; I’ve been out all day.

I ran journalctl -b and it is over 280K in size so I posted it on the test web site. You can view it at . One thing I did notice is that there is a large group of

“Jul 21 18:24:15 localhost.localdomain kernel: radeon 0000:01:05.0: GPU lockup (current fence id 0x00000000000000c6 last fence id 0x00000000000000c7 on ring 0)”

about 2 pages before the end. I suspect that this may indicate the problem. There is no video card, the screen is using the processor video. This machine used to be a server so I never installed any video or sound.

This machine will not boot from a USB so I dug out the original install DVD and booted the live image from it. Worked perfectly. Firefox displays as expected so I ran a video and that worked as expected so the graphics system seems OK. Can’t run memtest because this is a borrowed laptop and I have no idea how to burn a CD on it (or even if I can).

Without losing the data and all the work I did since the last backup at the end of June, is there any way to go back to the previous release (ie downdate the Fedora version)? This all happened when I let the automatic update run last Monday night.

You can copy your home directory to a separate disk if possible to preserve your user configuration. Then after reinstall copy back the destination to your home. Make sure to preserve permissions and ownership (use cp -a or rsync -aX)

Your system configuration needs other methods, I have no idea what you have so I can’t comment on it.

First of all, you could run Fedora live usb then backup your data. Just by copy-paste it on Nautilus.

After that, before you wan to reinstall the system, may be you could try to install old kernel first (because look like you still can login via tty). You could follow this link from Fedora Magazine

Find same kernel version I mention from my previous comment then, download, then install it.

Hopefully it help.

One must realize that there are a lot of hidden files/directories (dot files) under ones home directory.
The normal use of cp or copy/paste techniques using nautilus will not copy those hidden parts.

Using rsync will normally copy those parts and as noted above,with rsync -aX will retain all the existing attributes of each file & directory in the entire tree.

1 Like

Just update then using kernel 6.4.4 this day and so far all works normal.

I just updated to Fedora 6.4.4 and it still doesn’t work. Same symptoms: I get a nice login screen but if I hit enter to get the password prompt everything stops and the mouse cursor is lost too. If I wait a while the screen will restore to a different login prompt (different graphic) but still doesn’t allow login. The log from journalctl -b is posted as:

The previous log is still available at save.txt on the same URL.