After installing fedora 32 windows 10 is overwriting the grub

I installed W10 on my laptop with free space for fedora
then I installed fedora 32 ( CInnamon spin)
but now I have two problem
1- windows 10 is seems to overwriting grub
2- grub has no windows 10 on it

I tried sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
but my main thing which made me open this thread is still problem number 1 I couldn’t fix it.
Please help

For Problem #1- I found that amazing page that helped my EFI Boot Manager order
by doing the following
1- first knowing the numbers of my EFIs
2- Inactivating windows boot manager
sudo efibootmgr --bootnum #### --inactive
3- Ordering the numbers of my EFIs
sudo efibootmgr --bootorder ####,$$$$,&&&&,%%%%
where #### is Windows boot number.

still trying to figure out how to add the windows 10 to my grub menu as it is not working even with adding it thru 40_custom and grub customizer
I think I still have some syntactic errors

I also installed both windows 10 and Fedora32 on one hard drive and everything worked perfectly.
Try to do the following.
1, Windows 10 - Power Options - Turn off the Quick Start option.
“Control Panel→Hardware and Sound→Power Options→System Settings”, then disable the “Fast Startup” option in “Shutdown Settings”.
2, Restart and go to Fedora32, run:
sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
3、Reboot your PC.