After F37 Upgrade, GNOME Desktop Env Alert Sound Is Wrong and Unconfigurable

I’ve been using the ‘glass’ Alert Sound for as long as I’ve been using GNOME. All of a sudden, in F37, now the alert sounds is the ‘drip’, which isn’t even one of the options, and the ‘glass’ option is gone. But, worse than that, none of the Alert Sound options in GNOME Settings works. Does anyone know how to fix this?

With the new Gnome the alerts are under Settings → Sound and at the bottom of that panel. The “click” is somewhat similar to the older “drip”.

I don’t know how to add to or change those sounds.

Sorry Jeff, it was late and I didn’t even explain the problem correctly. I edited it.

  • the current alert isn’t one of the options and it isn’t the sound I had configured before the upgrade.

  • I see the options in the settings, but none of them work. Whatever I select, the alert noise is still ‘drip’, which doesn’t exist. The settings don’t work at all.

This might work:

  1. Install Gnome Tweaks
    $ sudo dnf install gnome-tweak-tool
  2. Create a folder for your custom alert sounds
    $ mkdir ~/.local/share/sounds/glass
  3. Create a index.theme file there:
    cat > ~/.local/share/sounds/glass/index.theme << EOF
    [Sound Theme]
  4. Copy your “Glass” sound effect file to ~/.local/share/sounds/glass/bell-terminal.ogg and ~/.local/share/sounds/glass/bell-window-system.ogg
    You might be able to find the sound effect in /usr/share/sounds/. I had a quick look at the Gnome source but couldn’t find glass.ogg.
  5. Restart Gnome (make sure you don’t have any unsaved work)
    $ sudo systemctl restart gdm
  6. Open the “Tweaks” application. Navigate to “Appearance” → “Sound”, and select “Glass”.


Wow, this is really annoying.

I like your suggestion, @fancyhatenjoyer , but my preferred solution would be to get one of the default options working, not use custom one. However, I think that’s the clue I needed, because it looks like your suggestion doesn’t work and that made me think themes aren’t working at all…

Remember, the alert sound is wrong. It’s not that I need to set it to something special, it is set to something special, and I cannot change it back to a normal thing. Why doesn’t the alert sound change when I choose one of the regular options? Am I the only one seeing this?

In fact, your method of custom sounds is actually the way the default sound options work, AFICT. I already have a directory ‘~/.local/share/sounds/__custom’, and in there, the index.theme file contains

[Sound Theme]

and the files in that directory look like this:

... 46 Jan  1 23:44 bell-terminal.ogg -> /usr/share/sounds/gnome/default/alerts/hum.ogg
... 46 Jan  1 23:44 bell-window-system.ogg -> /usr/share/sounds/gnome/default/alerts/hum.ogg

These files are being changed every time I select a new Alert Sound via the GNOME Settings > Sounds options menu. So, this is what the regular alert sound options are doing: changing these files. But, these aren’t the files that get played when I cause a terminal bell event. I’ve verified that the sound being played is actually usr/share//sounds/freedesktop/stereo/bell.oga. (I think this file has the ‘drip’ sound in it; and, maybe it used to have a different sound.)

I can prove this is what is happening by asking pactl to show me the latest sample files that were played after I cause the terminal bell event:

$ pactl list samples
Sample #0
        Name: bell-window-system
        Sample Specification: s16le 2ch 44100Hz
        Channel Map: front-left,front-right
        Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        Duration: 0.1s
        Size: 24.0 KiB
        Lazy: no
        Filename: n/a
                client.api = "pipewire-pulse"
                event.description = "Bell event"
       = "bell-window-system"
                media.role = "event"
       = "bell-window-system"
                media.filename = "/usr/share//sounds/freedesktop/stereo/bell.oga" <--this is sound I hear

In any case, GNOME doesn’t seem to be using my GNOME settings when a terminal bell event occurs. Since I see these user theme files changing, I wonder if I need to have the “User Themes” extension working. I didn’t think I was using it because I didn’t know the GNOME settings panel was changing a “theme”, but it got disabled during the upgrade, and several of the extensions had to be upgraded the first time I logged in after the upgrade. So, maybe that all makes sense.

I have turned the “User Themes” extension back on, but I think I need to logout and back in to see if that fixed it. Seems like it might work. I don’t feel like logging out right now, but I’ll check later.

Hey Paul, just made an account on here to wrap this up

Last night, I let the GNOME crew know about this bug after seeing your thread. I opened a request on the gitlab last night, and it was merged this afternoon. This bug should be fixed!

If you’d like a fix for now, delete the cached item .cache/event-sound-cache.tdb.*, and try running canberra-gtk-play -c never -i bell-window-system as a test.

1 Like

Thanks, @alexthezoomer ; looking forward to the fix arriving at my machine. I tried those commands and didn’t notice any change.

1 Like

Just restart your session, forgot to mention that too.

After several days, I rebooted my computer and, after login, the settings I chose from the GNOME sound settings were active. I’m not sure what fixed it, though, as I did two things prior to the reboot: 1) restored the user themes plugin to active state, and 2) tried clearing my sound cache and ran the specified canberra-gtk-play command as suggested. Possibly both were necessary.

I’m curious what the command is that you ran for canberra-gtk-play as I am experiencing the exact same thing.

Did you check the user theme plugin/extension? The command is above in Alexandre’s earlier comment.