Admin password resets every two weeks suddenly

Hi everyone,

since 6 weeks ago I am asked to change the admin password to a new one. I didn’t change anything in the settings to do so. How can I reset this?

Thanks for the answer!

Hello @pipeliner
What is the result of this command?
chage -l username
Where username is the username for which the password change is requested.
And, what do you mean with “the admin password”?


I have 2 users on my laptop. One user with admin right and another one with fewer right I use for occasional stuff.

When I turn on my laptop a message appears that I need to enter a new password for the admin user. This is in the login screen where I usually login with the account with fewer rights.

And this happens like every two weeks since 6 weeks and I didn’t change anything on my end.

Could you execute this command?
sudo chage -l username
Where username is the admin user?
The only thing that I can think of is that password expiration is set for such user.

thank you! after typing sudo chage -l username this was shown:

last password change: Apr 04, 2023
Password expires: never
Password inactive: never
Account expires: never
Minimum number of days between password change: 0
Maximum number of days between password change: 99999
Number of days of warning before password expires: 7

looks like I shouldn’t get asked to have the password changed, right?

Just can imagine that you have linked your root account with an online account like fedora?
Check “Settings” > “Online Accounts”

I don’t think so. I didn’t use the admin / root account for many months… could this be a bug then?
Just checked… no accounts added

Try to catch next time a screen shot with Fn & print screen

1 Like

Difficult to answer without having the full picture of the problem.

okay, thank you for the help so far. I will do a screenshot or a photo when this happens again!

I am not sure but the message that I need to reset my password never appeared anymore.

Maybe this was because I updated Fedora in my admin account (there was something that didn’t appear in my normal user account). This could be the solution.