Activate Cinnamon in Fedora 37

I installed Cinnamon in Fedora 37 - how can I use it?

Welcome to the Fedoraprojec @hdbender

Your question is not so clear for me, could you please be more precise?

If you where short because of missing English, please ask in German (my guess because of your name) I will translate it for you to English then.

How did you install it? With the Spin? Or with the package manager/Software tool?

If you installed it over the Workstation you have to klick on your user (while log in in GDM) and select the gear (Zahnrad) on the bottom right and select Cinnamon before typing the password.

1 Like

The desired desktop environment is selected at the logon screen. I chose this guide, because it has pictures of what to do at logon, but there are several others available. If you’ve already installed Cinnamon as you said, you can simply logoff and then log back in selecting Cinnamon as the DE.

Good luck, and welcome to the forum!


Quite old once (the pictures) :grin: , that’s why i mentioned the gear on the bottom right. I not understood why the nice place it had not was good enough.

Also documented here:

Thank you for your kind response.
Yes I’m German, but we can proceed in English.
What I did first - look for advises in Google:

sudo dnf -y group install "Cinnamon Desktop"
sudo reboot

On the login screen, select “**Cinnamon**” under the list of Desktop sessions available.
But no Cinnamon on login screen
echo "exec /usr/bin/cinnamon-session" >> ~/.xinitrc

No Cinnamon available

Then I tried to download Cinnamon spin, but was advised to have bittorrent first
Okay, downloaded bittorrent
downloaded cinnamon spin
received cinnamon.iso

But don't know what to do with that?

Thank you for your efforts

Ok, now it is clear.

If you want first help to fix the installation you made, we can try to fix that. Because I believe the
steps you done could have changed. As I do remember Cinnamon already comes with Wayland ?!

This seams to be ok exept the -y parameter. If you are a new to linux ? it is better not to use this parameter. This -y means everytime when you have to confirm with yes that the system goes ahead without confirming with y. This way you loose the important information if there is an error etc.

If Cinnamon comes with Wayland then startx is the wrong command.
We would have to confirm / check this before fixing what you already made.

If you let us know the link to the manual/tutorial you used, we try to finde the correct info or otherwise you just could:

Use The ISO file to test it for example:

  • In Virtualbox / Boxes (Gnome)
  • Creating a bot CD
  • Or create a live boot USB stick / sd-card, to test and afterwards install it.

Simplest way to create a boot usb-stick / sd-card is to use the Fedora mediawriter
You might have to install it first.

Start the mediawriter, chose your downloaded ISO and then the usb-stick / sd-card

It is really simple.

okay, ilikelinux,
I did it.
Problems from the beginning.
After booting from USB I wanted to install it but not possible on the same drive like fedora, even there is enough space.
Is this a complete new cinnamon distri of fedora? It was possible to install it on the windows partition and also on the Mint partition and also on the Data partition but it was not possible on Fedora partition where it belongs to be, even there is 75 GB free space.
However, I will not install a linux system on a windows partition, and why should I install Cinnamon Fedora on a Cinnamon Mint partition which is working perfectly - exept sound?
I didn’t install it, only tested it, but also not successful.
First I tried to play music videos - Just one from more than 20 videos was running.
From plain music files most had been possible, not all.
Movie videos not even one.
So it will not be helpfull to install it, even in case it might run some day. In this case I don’t need it anymore because in this case also Mint will run.
Plus I received an error message now that the Realtek audio device doesn’t function and will not be used:

installiertes rtl8821ce-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück

Correct driver for my new hardware is not available yet for my laptop, 1 month old. In my other laptop which is 2 years old the same Mint edition is running with sound.
I decided now to use Mint for all transactions and in case I need sound I will switch to Windows.
I thank you very much for your advises, and in case somebody still knows to solve my sound problem (after knowing the exact reason of the issue) would be great.
Thnks again and have a nice day

Fedora not distributes closed source code as codecs etc. This you have to install separately. I guess also on the live ISO they are not available. But even if it not gets saved you can install them to test in live mode. Just do not reboot. Them maximum you can do is log out and log in again.

Check my wiki page to see how to install the music and video codecs.

Same as with the codes … fedora not delivers closed source drivers by default. So you have to install them manually. But if you search with the search options for rtl8821ce you get a lot of information how to achieve this. Even with Linuxmint I guess you need them to install separately.

Just a “tipp” if you use a laptop, to substitute a wireless module is not so expensive and quite simple to achieve. But it will save you a lot of headache working with linux. If you take this in consideration it makes sense to create a new topic with your exact hardware information and ask for a good substitution.

There you identified the problem yourself.
The hardware does not appear to have the correct drivers due to (A) the hardware is too new, or (B) the specific hardware does not have linux drivers readily available. In any case it seems software is the cause and with adequate info can usually be fixed.

It was suggested you start a new thread for this and I agree.

1 Like

Thanks a lot for your expert information.
It seems to be possible to solve the problem.
Unfortunately - or should I say fortunately - I just received some requests which might bring me some profit, but must be finished immediately.
For the first I must proceed with the actual situation, but will come back here after some days/weeks.
Have a nice day,