Aarch64 Fedora not booting on Raspberry Pi3 B+

I’ve tried flashing multiple releases - Fedora 28 / 29 / 30.
I’ve tried different versions - Minimal / Server / Workstation.
I’ve tried writing the raw.xz images using BalenaEtcher.
I’ve tried writing the image on different OS - Windows 10 / Fedora 30.
I’ve tried using dd or the ‘arm-image-installer’ on Fedora 30 to write the raw image.
I’ve tried writing the image on the SD card by using an USB adapter as well as attaching it to a built-in card reader on a laptop (when using the USB adapter the SD card shows up as a “Removable Device” while when attached through the built-in SD card reader it shows up as a SD card).

None of the methods above work - all of them result in what can be seen in the attached screenshot, my guess is that something is off with the partitions, grub config or dracut config. I can mount the SD card on other computers and access the files on it. I’ve tried fiddling with various configs as well as adjusting the partition layout or the partition flags… I also tried flashing and/or recreating root and swap partitions over to a USB flash drive except the EFI and /boot partition to see if this works but with no success.

I can successfully flash ARMv7 Fedora images and they boot, I can also flash Raspbian or Arch Linux images and it will boot as well. However, Fedora AARCH64 does not boot no matter what I do so I’d like to determine if my Raspberry Pi3 B+ is faulty, the images are bugged or I’m simply doing something wrong.

1 Like

Forgot to actually include the following screenshot:

I’d like to try adjusting the fstab from UUID identification to /dev/sd* (effectively do ‘GRUB_DISABLE_LINUX_UUID=true’) but I don’t know:

1)How would it show up - would it show up as “/dev/sd*” or “/dev/nvme*”?
2)How could I chroot into it and regenerate GRUB and/or Dracut - I once tried doing this on Fedora 29 and hung up my system, should I have tried doing it from a Live Bootable environment instead?

Gave up and threw away Raspberry.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.