0ad issues: gui does not cover full screen, mouse pointer displayed and actually pointing at wrong locations

I tried to play 0ad today, and there’s something off here. It’s meant to be full screen—the app is full screen, but the 0ad GUI/display only takes the bottom left corner of the app window. Next, there’s an offset between where the mouse pointer is shown and what display element is being pointed at by it.

 rpm -qa \*0ad\*

I also tried the Flatpak from FlatHub, though, and see the same issue. I’ve created a new user, and I’ve also tried a different system—always seeing the same issue. So it’s a system issue, but not perhaps in 0ad—one of the underlying libraries?

Screenshot (this is of the full screen, the app window is actually taking up the full screen)

Screencast(doesn’t upload here):

Filed a bug too, but thought maybe folks here would have some ideas on how to debug the issue:


I tinkered with some options and found a workaround. If I use this:

0ad -xres=1240 -yres=720

it now occupies the full screen. So for some reason, it doesn’t scale up to my 1920x1080 screen resolution.

I can’t repro on F38 Xfce, X11, Nvidia with proprietary drivers. 0ad works correctly at 1920x1080.

Does toggling fullscreen with Alt-Enter do anything?

1 Like

For me Alt+Enter fixes mouse positioning. Have that issue on Fedora 38, Ubuntu 23.04 but for some reason not in Ubuntu 22.04 LTS, latest 0ad installed from PPA. Too lazy to dig into since Alt+Enter fixes it, so unfortunately I don’t have more infos to share.

1 Like

Aha! Yes, “alt + enter” does seem to fix it. If I hit that twice, the first time goes into windowed mode, an then fullscreens.

So the issue is that is just doesn’t start in fullscreen mode properly, I guess.

This is a better workaround than what I’d figured out :+1:

Update: Kalev noted that this could be this issue with mutter: